MyBB Central

Full Version: Quick theme problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey Labrocca! I notice you haven't applied to fix for the quick theme problem! Were you aware that there is one? Smile

Just in case you didn't and don't want to look for it, I have pasted it below!

zaher Wrote:The issue isn't in the mod it self, it is in MyBB functions, exactly build_theme_select function to fix it open inc/functions.php

find

Code:
if(!$tid)
    {
        $themeselect .= "</select>";
    }
replace with
Code:
if($tid)
    {
        $themeselect .= "</select>";
    }
The quick theme works fine for me.
No, I don't mean it doesn't work, but don't you notice it looks a little funny? It shouldn't be combined with the "contact us | mybb central | return to top | etc...."

This is a problem with 1.2.3 that Zaher found. Once you do that fix, it will also make the Quick Theme look right again! I was just trying to help. You can look it up on the mybb community if you'd like! Big Grin
Ahh..see in Opera it looks perfectly fine...didn't notice that in FF and IE it's creating a layout problem.

Thanks

I think I will redo the way it works anyways...I want it to work for guests as well and also I don't really like the placement.
The updated version I released works with guests!

Cheers,
Tikitiki
Yeah I hope mybb 1.4 has some better template work so that I can make a mybb demo site. Currently lots of images are hard-coded and not part of the Theme Images Path. That needs to be changed dammit.