MyBB Central

Full Version: Just need help with a simple template edit
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I added that "Share this thread" template change and it moved a colspan over one. I can't figure out which one it moved over though. I'm just new at this and need a little help getting familiarized with what changes what in the themes and templates. I almost just wish it had a layover like dreamweaver does (has what the page looks like on top and then the code on the bottom and highlights one when the other is clicked on either side), that would actually be freaking AWESOME. (lol @ maybe posting a plugin request for that XD)

Anyways, here's a screen shot of the problem:

[Image: 10pogf5.png]


Edit: what's up with the spoiler? It didn't post the link for me to open the image with. just plain text....?
By the way that happed to my forum also please have a look at this.
I have sorted that problem out before did you use the code as it was and can you copy the code and paist it here (all of it in that file).
(Apr 22, 2010, 04:46 AM)Devilson Wrote: [ -> ]I have sorted that problem out before did you use the code as it was and can you copy the code and paist it here (all of it in that file).

Yes, I copied and pasted the code directly where I was supposed to. It's a colspan problem. I remember from Omni's plugin regarding forum icons that I had this issue and I could never figure out which colspan it was that was causing it.
Code:
<tbody><tr>
        <td class="thead" colspan="7">
            <div style="float: right;">
                <span class="smalltext"><strong><a

7 should be 8

Code:
<tr>
<td class="trow_sep" colspan="7">Important Threads</td>
</tr>
<!-- end: forumdisplay_sticky_sep --><!-- start: forumdisplay_thread -->
<tr>

Same again 7 should be 8.

Edit: if that dont work im happy to sort it out for you.
(Apr 22, 2010, 07:32 AM)Devilson Wrote: [ -> ]
Code:
<tbody><tr>
        <td class="thead" colspan="7">
            <div style="float: right;">
                <span class="smalltext"><strong><a

7 should be 8

Code:
<tr>
<td class="trow_sep" colspan="7">Important Threads</td>
</tr>
<!-- end: forumdisplay_sticky_sep --><!-- start: forumdisplay_thread -->
<tr>

Same again 7 should be 8.

Edit: if that dont work im happy to sort it out for you.

WHERE is this edit taking place? That's the issue. I know how to make the edits and do the troubleshooting, I just can't find the template I'm editing to adjust those particular fields.
After reinstalling mybb i got the full template edits for you to do.

--------------------------------------------------------------------------------

ACP » Template Sets » Template Name » Forum Display Templates » forumdisplay_threadlist

Line 9:
Code:
<td class="thead" colspan="{$colspan}">

{$colspan} should be 8

Line 29:
Code:
<td class="tfoot" align="right" colspan="{$colspan}">

{$colspan} should be 8

--------------------------------------------------------------------------------

ACP » Template Sets » Template Name » Forum Display Templates » forumdisplay_threads_sep

Line 2:
Code:
<td class="trow_sep" colspan="{$colspan}">{$lang->normal_threads}</td>

{$colspan} should be 8

--------------------------------------------------------------------------------

ACP » Template Sets » Template Name » Forum Display Templates » forumdisplay_sticky_sep

Line 2:
Code:
<td class="trow_sep" colspan="{$colspan}">{$lang->sticky_threads}</td>

{$colspan} should be 8

--------------------------------------------------------------------------------

Hope this helped.
Yep! That fixed it! Smile Thanks bro, thanks a million! It was 9 instead of 8, glad you found this I spent hours looking in the WRONG spot haha. Smile
(Apr 23, 2010, 06:50 AM)MasterZuFu Wrote: [ -> ]Yep! That fixed it! Smile Thanks bro, thanks a million! It was 9 instead of 8, glad you found this I spent hours looking in the WRONG spot haha. Smile

NP but next time use the other thread.