MyBB Central

Full Version: Forum Login Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I just installed a new theme, but when I (and someone else) tried to log in, it would take your to the index, and ask you to log in again. To other people, you're logged in, but you still have the option to log in. Hopefully these screenshots help:


1) I type in my login details
[Image: 1242a34fefb54389b8b44f07998311e6.png]

2) After loading, it takes me here:
[Image: e6b2761d83ba457b62732ed3672a7305.png]

But when I look down to the forum stats, it says I'm online.
[Image: 9caaf0ffea6a8635568246d2af24e911.png]

I can post, etc., but it won't tell me I'm logged in.


Here's my header template.
Code:
<a name="top" id="top"></a>
<div id="header">
        {$welcomeblock}
        <div id="content">
            {$pm_notice}
            {$bannedwarning}
            {$bbclosedwarning}
            {$unreadreports}
            <navigation>
            <br />
MattRogowski at MyBB.com Wrote:Recently, there have been a lot of people having problems logging in and/or logging out of their forums. This also includes having to login after every action in the ACP.

Almost every time, this is due to incorrect cookie settings. This is easy to fix, and here's how.
If your URL is http://www.example.com, your settings should be:
Cookie Domain: .example.com
Cookie Path: /
If your URL is http://www.example.com/myforum/, your settings should be:
Cookie Domain: .example.com
Cookie Path: /myforum/
If your URL is http://subdomain.example.com, your settings should be:
Cookie Domain: subdomain.example.com OR .example.com
Cookie Path: /
If your URL is http://subdomain.example.com/myforum/, your settings should be:
Cookie Domain: subdomain.example.com OR .example.com
Cookie Path: /myforum/

If you are hosting on a localhost (i.e. a test forum on your computer), your cookie domain will usually have to be blank.

Also, if you have a port at the end of your board URL (for example, if your board URL is http://123.45.67.89:1234) set your cookie domain to .123.45.67.89 - basically remove the :xxxx from the end. If you have a directory at the end as well as a port (for example, if your board URL is http://123.45.67.89:1234/forum) set your cookie domain to .123.45.67.89 as above, and set your cookie path to /forum/ - the port number isn't needed anywhere.

If you cannot work out your cookie settings, you can use this cookie generator created by our very own DennisTT and it will attempt to give you the correct settings. It is also recommended that you do not change your cookie settings when you install your forum as they are usually correct in the installer.

You can view your current cookie settings by viewing the source code from a page of your forum. If your cookie settings are wrong, you probably won't be able to change them in the ACP as you may not be able to stay logged in. If this is the case, in order to change them, find a way to open and edit ./inc/settings.php and edit the new values into the file. Then, you MUST go to 'ACP > Configuration > General Configuration' and make the change here too. This is because although editing the file will make you able to log in, the settings aren't updated in the database, and when you next save any settings in the ACP, the old settings will come back.

Also make sure ./inc/settings.php is CHMOD to 666.


99% of the time, this will solve the problem. However, sometimes your browser is set to not accept cookies, and this will cause a problem. Here's how to check your browser is accepting cookies:
IE 6/7/8 - Tools > Internet Options > Privacy (tab) > Change setting to 'Accept All Cookies' > Apply > OK.
FF3 - Tools > Options > Privacy (tab) > Cookies > Accept cookies from sites > *tick* > Accept third party cookies *tick* > keep until > *they expire* > OK.
Opera 9/10 - Tools > Preferences > Advanced (tab) > Cookies > Accept cookies > *tick*.
Safari - Edit > Preferences > Security (tab) > Accept cookies > Always > *tick*.
Chrome - Spanner symbol > Options > Under the Hood (tab) > Cookie settings > Allow all cookies.

After changing any cookie settings it may be necessary to clear your browser's cookies and then try again.

Still not working??

If you're sure the settings are right (i.e. they show what they should do in the source code of a page), settings.php is CHMOD to 666, and you've cleared your browser's cookies, try this.

Download a copy of ./inc/settings.php, and then delete it from your server. It should regenerate itself, and just in case it doesn't, you can reupload your downloaded copy. When it regenerates like it should (you may need to click around a few times on the forum to get it to regenerate), we'll know that it's a clean, fresh, uncorrupted version, with all the settings fresh from the database, meaning we'll be sure that the file is OK. Then, clear your cookies again, and try to login again.

----------------------------------------

If you are having a problem of no CAPTCHA image showing, please upgrade to the latest version of MyBB as this was fixed in 1.4.5.

If you are getting a white screen when you login and you have recently merged to MyBB, see here: http://community.mybboard.net/thread-420...#pid302288

----------------------------------------

If you are still having trouble, please tell us your URL. If you still have a problem but only say 'I still have a problem' but give no URL, we cannot help you in any way at all.

Also, if you are still having problems logging in or out, please post in this thread rather than making a new one, as there is often 2 or 3 threads on this each day.

Thank you
Thanks a lot, but it didn't help. Sad
Clear your cookies / cache for the latest month.
I did, and this isn't happening with just me. It's the other members, too. They can post and make threads, but the header still welcomes them as a guest, and it says they're online.
It happened when I installed a new theme.
Try to browse around a little, it might be the theme.
I do think it's the theme, but I'm not sure on how to fix it.

Clear cookies, in the BROWSER,
Yup, tried that too.