MyBB Central

Full Version: MyBB Compression Not Working/Authorization Code Mismatch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've recently found a problem with my MyBB. I'm unsure exactly how long it's been going on. It hasn't been TOO long, but it's not compressing any files. If I go to the ACP and turn off GZip Page Compression everything works fine, but with it turned on and even set to zero, it gives me problems. On my end, the site loads just fine. It actually refreshes itself automatically right after it loads for some reason (only once though until you refresh it again for whatever reason). For my SysAdmin, he tells me the page doesn't even load at all. I'm using IE8 to access the site. Another thing is I have a validator hotkey placed in the footer. If you press alt+m then press the "enter" button, it'll show all validations (which it appears there are a lot of O.o).

When GZip Page Compression is enabled, even if set to zero, it won't validate the page and throws an error. Currently it's turned off.

I've tried a bit of troubleshooting. All recent plugins I've used have been disabled and the page refreshed, and nothing. I also changed the themes and theme templates to a theme that's not been touched by plugins or template edits, including a fresh copy of the default theme. Nothing, still not able to validate the page, and compression seems to still be the problem.

Can ANYONE tell me how to fix this issue? Or what to do to look for the problem? Please respond this time? As the last three threads of mine have been ignored for weeks...

-ZuFu
I've turned it back on for now just for testing purposes, but, I read somewhere that extra lines could cause the problem. Recently my browser has been adding lines when editing templates, so I turned off Codepress and took all those lines out. The problem is still there...I'm utterly at a loss as to what's going on. I don't want to remove gzip entirely because my site has a lot of high intensity things on the main page and several images. It's best to have it compressed so at to allow those with not-so-good bandwidth to be able to view the page as quickly as possible.

Site: ethical-hackers.org
Another issue I'm running into is I continuously get "Authorization Code Mismatch" when performing administrative functions such as to do with installing new plugins, uploading a new theme, etc. It's happening everywhere.
Yet again, another issue:

The "Quick Edit" option when editing a thread is gone, clicking the edit button takes you automatically to the "full edit" version.

I have a lot of plugins installed on my board and a few template edits. I can post a full list of all plugins on the board if you like...
well I had some plugin installed when I was new to mybb probably the first version of "GUESTS CAN'T VIEW THREAD" it disabled delete,edit,etc options for my site for moderators,administrators,if you have that try deactivating it!
I don't have that plugin, but I'm thinking it might just be a plugin that's causing it. I have several, over fifty plugins. Its too many I know, but some of them I need. Not all of them of course, but a lot of them I do.
Yes I too got same problem,I also posses many plugins and I can't deactivate them,to see it just follow the below guide,and as soon as you enter that code plugins won't be loaded and then test and see as plugins wouldn't be active and you will come to know if its a plugin problem or not

In your ./inc/init.php, find:

PHP Code:
define("TIME_NOW"time()); 

After it add temporarily:

PHP Code:
define("NO_PLUGINS"1); 

It will make your all plugins load as long as this code is added and you can see if this is a plugin problem or other as all plugins would be not active.Don't worry it won't deactive your plugins and remove settings but will stop them loading at runtime Smile
Hmmm....that's a pretty good idea. Unfortunately I don't have access to FTP at the moment and won't for a few days, so I can't edit that file. One other notice/report:

I'm using blueimp chat, http://www.ethical-hackers.org/chat and the chat isn't working either. Seems whatever is affecting my site is also affecting the chat (which realistically I think ONLY uses the database)...more troubleshooting? I suppose so.