MyBB Central

Full Version: Ajax Login Broken
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I edited the header of my forum to make it more relevant, I changed it from the original code to:
Code:
<div class="upper_panel">
<span class="float_right"><a href="http://kashmirforums.co.cc"><img src="http://kashmirforums.co.cc/board/images/home.png"/> Home</a><a href="http://aalaw-kashmircalls.org"><img src="http://kashmirforums.co.cc/board/images/aalaw.png" alt="" title=""/> Aalaw</a><a href="http://frontlinekashmir.com"><img src="http://kashmirforums.co.cc/board/images/fk.png" alt="" title=""/> Frontline Kashmir</a></span>
    
<!--
    lang.username = "{$lang->login_username}";
    lang.password = "{$lang->login_password}";
    lang.login = "{$lang->login}";
    lang.lost_password = " <a href=\"{$mybb->settings['bburl']}/member.php?action=lostpw\" class=\"login\">{$lang->lost_password}<\/a>";
    lang.register_url = " <a href=\"{$mybb->settings['bburl']}/member.php?action=register\" class=\"register\">{$lang->welcome_register}<\/a>";
    lang.remember_me = "{$lang->remember_me}";
// -->
</script>
<div id="ql_condense"><span id="quick_login">{$lang->welcome_guest} <a href="{$mybb->settings['bburl']}/member.php?action=login" onclick="MyBB.quickLogin(); return false;" class="login">{$lang->welcome_login}</a><a href="{$mybb->settings['bburl']}/member.php?action=register" class="register">{$lang->welcome_register}</a></span></div>
</div>
<div class="middle_panel mp_round" onclick="location.href='{$mybb->settings['bburl']}';">
      <h1 class="ts_round"  id="thetitle"><a href="{$mybb->settings['bburl']}">{$mybb->settings['bbname']}</a></h1>
</div>

I only changed the first few lines and didn't touch the rest of it. Now, if I click the AJAX "Login" button, I get the following instead of "Login" and "Remember Me":

[Image: undef.png]

This is going to be a pain in the backside for newer users, and it makes the forum look bad. I want to release this forum to the public soon, and this makes the deadline seem even harder to reach.

My forum can be found here.I would really, really appreciate some help.
Any help guys? This really is my last hope, I've tried MyBB.Com & SupportForums to no avail yet. Please help Smile
I know youll get language problems for differnet users, but try changing the following in the code

{$lang->lost_password} to Lost Password?
{$lang->welcome_register} to Regsiter
(Apr 04, 2011, 06:06 PM)CyberTechForums Wrote: [ -> ]I know youll get language problems for differnet users, but try changing the following in the code

{$lang->lost_password} to Lost Password?
{$lang->welcome_register} to Regsiter

Doesn't work :/
Can you paste the old working code ?