MyBB Central
Tabbed Menu v2.0.2 - Printable Version

+- MyBB Central (http://www.mybbcentral.com)
+-- Forum: Mybb 1.6x Series Topics (http://www.mybbcentral.com/forum-34.html)
+--- Forum: Mybb 1.6x Official Central Plugins and Hacks (http://www.mybbcentral.com/forum-35.html)
+--- Thread: Tabbed Menu v2.0.2 (/thread-7687.html)



RE: Tabbed Menu v2.0.2 - Yin - Mar 16, 2012

Ok so everything is working fine for admin now, but as a guest or regular member, all categories (Aside from those they don't have perms for) are shown in both tabs.

I've purposely put my announcement forums up top since everyone has access to it (except banned people), but guests and regular registered members are still not working. It just shows my index url with a # sign after it. All categories show up on both tabs for guest or registered members. Also, the tabs don't memorize. If I refresh my page, it goes back to the first tab

Will someone help me with this?
I'm pretty sure I'm setting it up properly.


RE: Tabbed Menu v2.0.2 - dalawh - Mar 17, 2012

(Mar 16, 2012, 12:19 PM)labrocca Wrote:
(Mar 15, 2012, 07:54 PM)dalawh Wrote: I have another suggestion. Make it so you can hide certain tabs to certain members.

Members already can't deal with setting this up. If I added that it would only complicate this more.

It's your decision, but it would be nice. Also, can you add a way to order each tab or at least tell me how?


RE: Tabbed Menu v2.0.2 - hostpro - Mar 17, 2012

Just when you make them add them in the order you want them in

~Hostpro


RE: Tabbed Menu v2.0.2 - hostpro - Mar 17, 2012

I have now deleted all the files I had, re-downloaded, re-installed, re-activated so everything is fresh.

I go to the tabbed menu option under forums and posts and assign every category to a tab with no category in more than one tab.

I then go to my forum and the first tab is working, however every single other tab does not.

Does anybody know how to fix this?

~Hostpro


RE: Tabbed Menu v2.0.2 - dalawh - Mar 17, 2012

(Mar 17, 2012, 09:28 AM)hostpro Wrote: I have now deleted all the files I had, re-downloaded, re-installed, re-activated so everything is fresh.

I go to the tabbed menu option under forums and posts and assign every category to a tab with no category in more than one tab.

I then go to my forum and the first tab is working, however every single other tab does not.

Does anybody know how to fix this?

~Hostpro
I had the same issue. It turns out that it was because of the forum permissions. BleepyEvans was help me out with this one and the easiest way is to delete all your category and forums and create all the categories and forums fresh with regular permissions, add it under the tabs, then change the permissions. Make sure the first category under each tab can be seen by everyone, otherwise it does not work. Hope that helped.


RE: Tabbed Menu v2.0.2 - hostpro - Mar 17, 2012

Oh... That may be why because I have a tab for VIP members and the only category in it was VIP only.

So if I put a category in there that can be seen by everybody it will work?

~Hostpro


RE: Tabbed Menu v2.0.2 - labrocca - Mar 17, 2012

We've tried to explain in simple terms how to properly setup permissions and sorting order but people just don't get it.

Basic scenario is people say "I have problem. First tab works and then all the others don't and all the categories are under one tab". We say "read troubleshooting section because it's a permission issue or template issue". I have yet to see a problem with this plugin not covered by our troubleshooting section. Only say many ways I can say the same thing.




RE: Tabbed Menu v2.0.2 - Yin - Mar 17, 2012

Quote:Ok so everything is working fine for admin now, but as a guest or regular member, all categories (Aside from those they don't have perms for) are shown in both tabs.

I've purposely put my announcement forums up top since everyone has access to it (except banned people), but guests and regular registered members are still not working. It just shows my index url with a # sign after it. All categories show up on both tabs for guest or registered members. Also, the tabs don't memorize. If I refresh my page, it goes back to the first tab

Will someone help me with this?
I'm pretty sure I'm setting it up properly.

What about the problems I am having?


RE: Tabbed Menu v2.0.2 - iRun - Mar 18, 2012

Why does it minimize the forums I don't want to be shown?

[Image: IdxbN.png]

It worked before on my other forum.


RE: Tabbed Menu v2.0.2 - labrocca - Mar 18, 2012

Do a validation on your page. I suspect you have template problems possibly unrelated to the plugin but you also may not have installed this correctly.