REGISTER or LOGIN to have the annoying ads removed.
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IPN Paypal Subscriptions
#51
niceSmile i need that modSmile thanks
#52
Do you have beta 1.0b Jude? The subscription refunds and eot are working. Tested via sandbox.
#53
Yeah, I uploaded the new one. The refunds work, but not the EOT. I can try it again and let you know if there is any different result, but my test mover was not moved after the end of their subscription. It wasn't until I refunded the money that they were moved. The refunds didn't work in the previous version, right?

I just checked the ACP and the eot is in there now, but it wasn't when I checked yesterday. Maybe all the downtime my site was having threw off things? I'll try it again and see what happens and let you know.

Dang it, I give up. Now it's not working at all!
#54
I had a one day EOT to test this and it worked fine. Check your logs for the EOT txn.

Quote:I just checked the ACP and the eot is in there now, but it wasn't when I checked yesterday.

The EOT arrives I believe at a certain time from Paypal and it may not be the exact hour of the original subscription. I think they might do cron jobs to get these out. Not sure but I signed up in the afternoon and all my renewals seemed to be in the morning. Same happened with my EOT.

What do you have your usergroup after subscription set for? For me...it worked flawlessly by placing me back into regular usergroup 2.

If your site is having downtime or timeouts that can certainly effect the script. You need to be connected for it to work. BTW...do you have the debug enabled? It can help troubleshoot this for you. Set the email and debug to 1. Now everytime your ipn page gets hit you will get a variety of emails. Each has a seperate error or notice to what happened.

As far as I can tell..the script is working 100% right now to how it's designed.

Quote:It wasn't until I refunded the money that they were moved. The refunds didn't work in the previous version, right?

Yes the refund is fixed now where it will trigger the group move. But EOT will as well. Especially if you are getting the EOT in logs. Maybe you just didn't wait long enough.
#55
I don't know what logs you are talking about, and like I said, it isn't working at all now, so I don't know what's going on.

By the way, I think testing in a real world setting would be more reliable than the sandox, which I couldn't even get set up.

edit: you're talking about the ipn subscriptions area? yeah, I've checked there. I even changed the file to send me emails with errors and tried again. Still nothing, and I didn't get any emails. I'm giving up for now, since I don't need this frustration.

edit again: I just now got the PM from 40 minutes ago about the subscription. That's why nothing was happening. Didn't expect it to take that long, since it didn't the last time I tested it.
#56
If paypal gets an error...the resend. They MIGHT have had a problem with connecting to you. IPN is suppose to be instant and for me...it is. However you been having all types of site connection problems lately which could be the cause of your problems.

I know the new code works since the sandbox is identical to Paypal live. If you want more help Jude hit me on IM. I can help you setup sandbox testing..it's just a little time consuming.

1. edit the subscribe.php $form... change from http://www.paypal.com to http://www.sandbox.paypal.com
2. edit the root/myipn.php $mode variable to 2 (which is sandbox)
3. Setup a test account at the developer area https://developer.paypal.com/
4. Setup a seller and a buyer test account. Make sure seller is verified and business. This can be done but I don't remember every step.
5. begin testing...

When you're satisfied undo your file changes. The testing process can be cumbersome and that's a lot of the reason I went to paid support here at Mybb Central. Just to get to this beta I have spent about 30 hours on this.

Seriously though..I am very confident the plugin works properly now. Even when I originally beta 1a I knew refunds and eot weren't working..I just hadn't figured out why yet.

Quote:I don't know what logs you are talking about, and like I said, it isn't working at all now, so I don't know what's going on.

The admincp subscription logs. I have it setup where EVERY transaction to the IPN that hits your site is logged. Even if no action is resulted it should log what paypal is sending you.
#57
Yeah, I realized what logs you were talking about. It just seems that it takes quite a long time for anything to go through now. It was immediate but is now taking up to an hour to hit. I didn't realize that's what was happening, so I'll run through another subscription and won't refund to see how long it takes to send the eot and put the member in the specified group.

Also, I notice that sometimes in the logs, there is nothing listed by the action. I'll post a screenshot so you'll know what I'm talking about. I'm assuming that it's when the refund goes through, since I've seen the descriptions for all of them except for that.

Less than 1 minute ago" />   
#58
Yeah that was the problem before with my logic. Even though it's suppose to have a txn_type it doesn't...so my script while checking for those parameters didn't see them and then didn't log the action. I have it logging any time paypal says hello to myipn.php now.

I will probably add another column so you can see what those transactions are. They are "Completed" transactions for payments.
#59
OK, it seems to be working fine now. Don't know what was going on yesterday, but I have installed it on my main forum and will see how it goes! Big Grin
#60
Great...glad to hear it. Smile

I been waiting for your post all day.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Paypal integration plugin and SHOUTcast integration?? iJoe 7 4,968 Jan 11, 2008, 12:00 PM
Last Post: Dragonheart

Forum Jump:


Users browsing this thread: 1 Guest(s)