REGISTER or LOGIN to have the annoying ads removed.
Thread Rating:
  • 6 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Default Message v2.0
#31
Whenever I add "[" symbol I get an error.
Also, I can't use HTML because HTML is escaped in regular MyBB forum posts.
#32
What error do you get? I just tried it without any problems at all.

What EXACTLY are you typing? I didn't escape the string so if you are using a single quote ' then please just escape it like this \'
#33
That's awesome.
#34
(Feb 28, 2009, 01:37 PM)labrocca Wrote:
Quote:Also, consider supporting BBCode. I feel that it would be a useful addition to this plugin.

It should work fine to add almost whatever code you want.

Hi,

1) Can I use a MyBB variable like custom profile fields ('fidx')?
2) Will a PHP If/Else statement work also?

Thanks
#35
A great addon.
#36
@labrocca, sorry to ask this now, but I don't get it... Is this version 1 or 2 ? The download says 1, the plugin (in my AdminCP) says 1, but the thread (here) says it's version 2. Can you tell me where am I wrong? I ask this because I keep thinking that I need to update the plugin i have in my forum.
Of two equivalent theories or explanations, all other things being equal, the simpler one is to be preferred.
simplified translation of Occam's razor

[Image: 82pwtx]
#37
It's version 2. I probably didn't label the version correctly. Version 1.0 was for Mybb 1.2x.
#38
Thanks. I'll mark it as "up to latest version".
Of two equivalent theories or explanations, all other things being equal, the simpler one is to be preferred.
simplified translation of Occam's razor

[Image: 82pwtx]
#39
Omni, I installed the plugin exactly as it stated and did everything correctly, but I get this error:

Code:
MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
    1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's optimal state. Psinetic/Site Owner' WHERE fid='2'' at line 2
Query:
    UPDATE mybb_forums SET `defaultmessage`='Notice to Internet Explorer Based Web Browser Visitors: If you are using Internet Explorer you may notice several images are either not showing up, or do not fit the theme. Please be noted: Internet Explorer 7 and below cannot see .png extension type images. It also cannot see transparent images, as you may see our logo is transparent, but you can see a light blueish color. Also our favicons for our forums, you may notice they too are visible in internet explorer. If you are using Internet Explorer to visit our forums, we recommend you visit the forums with FireFox internet browser. This browser allows you to see our site in it's optimal state. Psinetic/Site Owner' WHERE fid='2'

Any ideas?
#40
Seems the ' in it's isn't escaped and is closing the query. Personally I'd remove the ' until labrocca can say why it's happening.


Possibly Related Threads...
Thread Author Replies Views Last Post
  Private Message "No Subject" 88power88 1 1,928 Jun 15, 2010, 04:33 AM
Last Post: Elite Dash
  Found a Bug at Default Messages 1.0 Stein 2 2,449 Apr 19, 2009, 05:06 AM
Last Post: Stein
  Display message to Guest users AdamDV 9 6,870 Apr 04, 2009, 04:13 PM
Last Post: labrocca
  Sidebox on the message view ustein 3 2,496 Feb 12, 2009, 11:05 PM
Last Post: labrocca
  [1.4] Reported Posts Message jnd52 3 4,071 Sep 12, 2008, 05:01 PM
Last Post: andreidanielb

Forum Jump:


Users browsing this thread: 1 Guest(s)