REGISTER or LOGIN to have the annoying ads removed.
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[r4] Tag Cloud v1.2
#1
MyBB Version: MyBB 1.4
New Settings: 9
New Templates: 5
DB Changes: 1
File Changes: 0
Files: 5
  • .htaccess
  • tagcloud.php
  • ./inc/plugins/tc.php
  • ./inc/plugins/tc_update.php
  • ./jscripts/tagcloud.js
Images: 0
Settings:
  • Status
  • Get_Method; Threads Subject Or Box To Enter
  • Maximum Tags In Cloud
  • Minimum Tag Length
  • Excluded Words (a,the,for ... )
  • Filter Badwords?
  • AutoCreate Tags?
  • Forums Where Tags Can Be Used
  • Show TagCloud On Index
Install:
  • Upload tagcloud.php into your rootfolder
  • Upload ./jscripts/tagcloud.js into your ./jscripts/ folder
  • Upload ./inc/plugins/tc.php into your ./inc/plugins/ folder
  • Upload ./inc/plugins/tc_update.php into your ./inc/plugins/ folder
  • Go to your PluginManager and Activate the "TagCloud v1.2" Plugin.
  • If you want to Update your Older Threads (before activating the TagCloud Plugin) with Tags; you can activate the TagCloud Update File ! Make sure all your settings are set like you want to before activating.

Note:

#1
If you want SEO URLS for your tags; upload the included .htaccess file.
Also make sure your Enable search engine friendly URLs? setting is set to YES; not Automatically detect ... !
TagLinks will look like http://<yoururl>/tags/<tagname>

#2
I'm not into charset shit; so if you have a language with for me weird chars in it; the links/tagsearch probably won't work.
So i'm making this plugin license free so you can modify to your needs.


Attached Files
.zip   TagCloud.zip (Size: 8.79 KB / Downloads: 147)
#2
thank you for sharing Smile
#3
sorry but, It doesn't allow Turkish charakter (şğüöçı)
#4
(Apr 09, 2009, 04:23 PM)accessled Wrote: sorry but, It doesn't allow Turkish charakter (şğüöçı)

#2
I'm not into charset shit; so if you have a language with for me weird chars in it; the links/tagsearch probably won't work.
So i'm making this plugin license free so you can modify to your needs.

sorry
#5
(Apr 09, 2009, 04:23 PM)accessled Wrote: sorry but, It doesn't allow Turkish charakter (şğüöçı)

Try to contact 'dared'; he seems to have updated it for Turkish Users.
#6
(Apr 10, 2009, 09:36 AM)LeX- Wrote:
(Apr 09, 2009, 04:23 PM)accessled Wrote: sorry but, It doesn't allow Turkish charakter (şğüöçı)

Try to contact 'dared'; he seems to have updated it for Turkish Users.

accualy LeX- i did it when we are 1.2.x for latin chars. when 1.4.x released i asked labrocca for this plugin via pm, i tried to reach you and also asked some other plugin authors to make a tag cloud for 1.4.x but no one did it. then one day i and Türküz update plugin to 1.4.x (latin & utf). i send you just utf files. if board's charset is utf tag cloud works fine. if board's charset is latin1 or latin5 it doesnt works correctly. but i was added latin support for when MyBBDestek.com was latin ( themem is owner of MyBB Destek and he is also a Subscriper on here http://www.mybbcentral.com/user-1825.html and i think its not a big deal to get it. if it is sorry but i didnt gave it anyone else. ). But right now i dont want latin boards anymore. latin boards cant uses any kind of xmlhttp correcty and we also made a tutorial for converting charset latin to utf. if someone wants to use it he/she have to convert their board to utf plz.

but if there are another users with latin boards (Subscriped central users only) can write replies on this thread and i will send them latin files.
#7
So atlast LeX- Came back again!
#8
quick question Lex ?

is there away to have a tag clound on index somehow, if so can you explain please
#9
* Create A New Setting
Configuration - Settings - Add New Setting
Code:
Title : TagCloud __Index
Description: Show TagCloud On Index?
Group: TagCloud Settings
Display Order: 9
Identifier: tc_index
Type: On / Off Choice
Value: 1

* Create A New Template called index_cloud
Code:
<table class="tborder" width="250px;"><tr><td class="thead">Tag Cloud</td></tr><tr><td class="trow2" width="100%" valign="top">{$tag}</td></tr></table><br />

* Re-Upload ./inc/plugins/tc.php

* Open your index template and add {$cloud} where you want to display it; It has a fixed width; you might need to change that.
#10
ok just woke up and saw that there was a error on page ( bottom of page ) that yellow explanation, now i think it is something to do with the brackets around tags but then again i have no idea

   

once we fix the errors then i will for sure try out how you explained to in your explanation on how to get it to show on Index


Forum Jump:


Users browsing this thread: 1 Guest(s)