REGISTER or LOGIN to have the annoying ads removed.
Thread Rating:
  • 2 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[r4] Thread Prefixes
#1
MyBB Version: MyBB 1.4
New Settings: 4
New Templates: 1
DB Changes: 1
File Changes: 0
Files: 4
  • ./inc/plugins/tprefix.php
  • ./inc/plugins/tprefix_update.php (Only for v3.0 owners)
  • ./inc/languages/english/admin/config_tprefix.lang.php
  • ./admin/modules/config/tprefix.php
Images: 0
Install:
  • Upload everything like its stored in the .zip file!
  • Go to your PluginManager and Activate the "Thread Prefixes" Plugin. (*)
  • * If you still run an old version of this plugin activate/deactivate ./inc/plugins/tprefix_update.php before activating the new version.
Settings:
  • Status
  • Default Prefix Format
  • Forums Where Tags Must Be Used !
  • Error Message
What:
* Makes It Possible To Add A Prefix To Your Thread. Such as [ PHP ]
* When creating/editing a thread there should be a box where you can select a prefix ( if the Admin has added any ) !
* Search by Prefix [Multiple Select] ( Search Page )
   

**

   


Note: After Update To Latest Version, Some of Your Threads Which Had A Prefix Suddenly Don't Show It Anymore ?
Upload && Activate this pluginfile once;
http://www.mybbcentral.com/thread-2834-p...l#pid18979


Attached Files
.zip   tPrefix.zip (Size: 10.86 KB / Downloads: 143)
#2
When i do an upgrade of the forum i loss template and data of prefix plugin?
#3
I can't guarantee the template things; as an update of MyBB requires a revert of the newthread/editpost template then you need to add the variables manually, not a biggie =P

And you won't loose any data of the prefixes if you update your forum.
#4
Hmmm... how to downgrade to v3.0? Smile
#5
I don't have that version anymore, so don't know =P
Why do you want that version ?
#6
the prefix is not shown in the list of new topics (search.php?action=getnew).

problem on my side?
#7
No; its not coded like that.
The prefix isn't added to the Threadtitle while adding a new thread; its saved into a seperated column. Why? Less work if you edit the prefix. Else it first needs to determ the old prefix in the title; then replace it with a new one; and update the title.
Maybe gonna think of another way in the next release.

**
Edit: I changed the code.
Reupload ./inc/plugins/tprefix.php
Let me know if there are any issues with the new code.
#8
great LeX, thank you!

but after i copied the new version, i cant see all the old prefix.
when i edit an old post with prefix, the prefix is set in the prefix list, it is only active/shown after i safe the thread again.
#9
Yeah can't do anything about that =P i'm not into writing a new update file =/
It now adds the prefix to the subject itself rather that adding it towards the subject when viewing the thread. Probably weird talk; ex.
Subject: 'my own thread'
Previous: subject stored in DB as 'my own thread'; only adds the prefix when you view the thread.
New: subject stored in DB as '[Prefix] my own thread'
#10
my english is rather bad, so i am not sure that i understand you.

is there no way to get the old prefix back, right?
so the plugin is not for productive use ready, right?


Possibly Related Threads...
Thread Author Replies Views Last Post
  [r4] Reported Post Gets Thread LeX- 18 15,002 Sep 21, 2010, 11:06 AM
Last Post: Gigius
  [r4] Who's Viewing This Thread LeX- 35 24,999 Aug 23, 2010, 03:32 AM
Last Post: BeMisz
  [r4] Default Thread/Post Icon LeX- 11 8,836 Jul 15, 2010, 09:02 AM
Last Post: x-Treme
  [r4] Notification After Thread/Post Moderation LeX- 8 6,693 Oct 06, 2009, 07:25 PM
Last Post: technoman

Forum Jump:


Users browsing this thread: 1 Guest(s)