Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[r4] Notification After Thread/Post Moderation
#1
MyBB Version: MyBB 1.4
New Settings: 1 [ Posting Group ]
New Templates: 0
DB Changes: 0
File Changes: 0
Files: 3
  • ./inc/class_moderation.php
  • ./inc/plugins/nam.php
  • ./inc/languages/english/nam.lang.php
Images: 0
Install:
  • Upload ./inc/plugins/nam.php into your ./inc/plugins/ folder
  • Upload ./inc/languages/english/nam.lang.php into your ./inc/languages/english/ folder
  • Upload ./inc/class_moderation.php (MyBB 1.4.6)
  • Go to your PluginManager and Install/Activate the "Notification After Thread/Post Moderation" Plugin.

Settings:
  • Status ( Posting Group )

What:
* Sends Out a PM to Thread/Post Owner When Someone ...
  • (un)Approve Post(s)
  • (un)Approve Thread(s)
  • Open/Close Thread(s)
  • Delete Thread(s)
  • Delete Post(s)
  • Delete Poll
  • Split Posts
  • Move/Copy/Merge Threads

It was originally made for MyBB 1.2 ; Everything was tested and worked !
Now after upgrade to MyBB 1.4 i only tested the first 8; the rest should still work; if not ... report !


Attached Files
.zip   NotificationAfterModeration.zip (Size: 14.33 KB / Downloads: 108)
#2
Interesting. Might use it.
Regards,
faviouz
#3
Thank You very much for this release! I'll check it in a few days Smile
#4
Quote:Status ( Posting Group )

where I can see the setting? Smile
#5
Nice. Thanks Smile
#6
Nice mods.
Work perfectly, except here:
- both inline and moderator option can merge post, but no PM notified (pict.1)
- inline split post success, but no PM Notified (pict.2)
- inline and moderator option delete post, does not send Notified Smile

It seem, prefix database causing those error?


But so far, this is the best mod which have "human manner"
and please support for trash can forum http://community.mybboard.net/thread-492...60865.html Smile


Attached Files Thumbnail(s)
       
#7
Another bug issue: when I delete post, in PM notify don't show title text.
#8
FBI: you have right.
On my forum, when I split post, I have SQL bug like you. Something wrong with prefixes of database ("mybb_" shouldn't twice before "_posts").

LeX-: fix it, please Smile
#9
was there a fix to this yet cause it would work hand to hand with moderating a thread and post the other plugin, waiting for reply on this plugin

thanks


Possibly Related Threads...
Thread Author Replies Views Last Post
  [r4] Reported Post Gets Thread LeX- 18 17,490 Sep 21, 2010, 11:06 AM
Last Post: Gigius
  [r4] Who's Viewing This Thread LeX- 35 29,463 Aug 23, 2010, 03:32 AM
Last Post: BeMisz
  [r4] Thread Prefixes LeX- 34 28,496 Jul 22, 2010, 02:02 PM
Last Post: haynes11
  [r4] Default Thread/Post Icon LeX- 11 10,352 Jul 15, 2010, 09:02 AM
Last Post: x-Treme
  [r4] Notification after Reputation LeX- 10 6,696 Apr 22, 2010, 04:35 PM
Last Post: scarface

Forum Jump:


Users browsing this thread: 1 Guest(s)